Please find below the latest Letter of Announcement from EMVO on the fact that the EU Hub no longer accepts connections with Transport Layer Security (TLS) versions prior to 1.2.

EMVO LoA